{"answers":{"affected":"3 open source packages ship an affected version, including ansibleguy-webui.","exploited":"There is no known exploitation of CVE-2024-36110 in the wild and no public exploit code.","fix":"Upgrade ansibleguy-webui to 0.0.21 or later.","what":"CVE-2024-36110 is a high-severity cross-site scripting vulnerability in ansibleguy webui, published on 28 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-36110 and fix it if it is affected.\n\nWhat it is: CVE-2024-36110 is a high-severity cross-site scripting vulnerability in ansibleguy webui, published on 28 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-36110 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansibleguy-webui (PyPI): affected all versions; fixed in 0.0.21\n- ansibleguy-webui (PyPI): affected all versions; fixed in 0.0.21\n- ansibleguy-webui (PyPI): affected all versions; fixed in 0.0.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-36110/ (Markdown: https://insights.sbomify.com/CVE-2024-36110/index.md)","id":"CVE-2024-36110","markdown":"https://insights.sbomify.com/CVE-2024-36110/index.md","name":"CVE-2024-36110","record":{"aliases":["GHSA-927p-xrc2-x2gj","PYSEC-2026-1126"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible WebUI","requires_auth":"low_privilege","summary":"Attackers can inject HTML into Ansible WebUI forms, leading to script execution in the victim's browser when job actions are executed.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ansibleguy-webui is an open source WebUI for using Ansible. Multiple forms in versions \u003c 0.0.21 allowed injection of HTML elements. These are returned to the user after executing job actions and thus evaluated by the browser. These issues have been addressed in version 0.0.21 (0.0.21.post2 on pypi). Users are advised to upgrade. There are no known workarounds for these issues.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in ansibleguy-webui","id":"CVE-2024-36110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":3,"n_references":4,"next":{"headline":"KubePi's JWT token validation has a defect","id":"CVE-2024-36111"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.21"],"introduced":["0"],"last_affected":[],"package":"ansibleguy-webui","purl":null,"source":"GHSA-927p-xrc2-x2gj"},{"ecosystem":"PyPI","fixed":["0.0.21"],"introduced":["0"],"last_affected":[],"package":"ansibleguy-webui","purl":"pkg:pypi/ansibleguy-webui","source":"GHSA-927p-xrc2-x2gj"},{"ecosystem":"PyPI","fixed":["0.0.21"],"introduced":["0"],"last_affected":[],"package":"ansibleguy-webui","purl":"pkg:pypi/ansibleguy-webui","source":"PYSEC-2026-1126"}],"prev":{"headline":"Cross-site Scripting with Markdown rendering in CoCalc","id":"CVE-2024-36109"},"products":["webui"],"published":"2024-05-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["ansibleguy"]},"summary":"Attackers can inject HTML into Ansible WebUI forms, leading to script execution in the victim's browser when job actions are executed.","url":"https://insights.sbomify.com/CVE-2024-36110/"}