# CVE-2024-36110: Cross-site scripting in ansibleguy-webui

> Attackers can inject HTML into Ansible WebUI forms, leading to script execution in the victim's browser when job actions are executed.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-927p-xrc2-x2gj, PYSEC-2026-1126

## What is CVE-2024-36110?

CVE-2024-36110 is a high-severity cross-site scripting vulnerability in ansibleguy webui, published on 28 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ansibleguy-webui is an open source WebUI for using Ansible. Multiple forms in versions < 0.0.21 allowed injection of HTML elements. These are returned to the user after executing job actions and thus evaluated by the browser. These issues have been addressed in version 0.0.21 (0.0.21.post2 on pypi). Users are advised to upgrade. There are no known workarounds for these issues.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-36110?

3 open source packages ship an affected version, including ansibleguy-webui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansibleguy-webui` | PyPI | All versions | 0.0.21 |
| `ansibleguy-webui` | PyPI | All versions | 0.0.21 |
| `ansibleguy-webui` | PyPI | All versions | 0.0.21 |

## How do I fix CVE-2024-36110?

Upgrade ansibleguy-webui to 0.0.21 or later.

## Is CVE-2024-36110 being exploited?

There is no known exploitation of CVE-2024-36110 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36110 and fix it if it is affected.

What it is: CVE-2024-36110 is a high-severity cross-site scripting vulnerability in ansibleguy webui, published on 28 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-36110 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansibleguy-webui (PyPI): affected all versions; fixed in 0.0.21
- ansibleguy-webui (PyPI): affected all versions; fixed in 0.0.21
- ansibleguy-webui (PyPI): affected all versions; fixed in 0.0.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36110/ (Markdown: https://insights.sbomify.com/CVE-2024-36110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36110
- OSV: https://osv.dev/vulnerability/CVE-2024-36110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36110/
Summaries are generated and may contain mistakes; the official description above is the record.
