# CVE-2024-36112: Nautobot dynamic-group-members doesn't enforce permission restrictions on member objects

> Users with dynamic group view permissions can list member objects regardless of their specific object view permissions, exposing unauthorized data.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-qmjf-wc2h-6x3q, PYSEC-2024-166

## What is CVE-2024-36112?

CVE-2024-36112 is a medium-severity missing authorization vulnerability in nautobot, published on 28 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nautobot is a Network Source of Truth and Network Automation Platform. A user with permissions to view Dynamic Group records (`extras.view_dynamicgroup` permission) can use the Dynamic Group detail UI view (`/extras/dynamic-groups/<uuid>/`) and/or the members REST API view (`/api/extras/dynamic-groups/<uuid>/members/`) to list the objects that are members of a given Dynamic Group. In versions of Nautobot between 1.3.0 (where the Dynamic Groups feature was added) and 1.6.22 inclusive, and 2.0.0 through 2.2.4 inclusive, Nautobot fails to restrict these listings based on the member object permissions - for example a Dynamic Group of Device objects will list all Devices that it contains, regardless of the user's `dcim.view_device` permissions or lack thereof. This issue has been fixed in Nautobot versions 1.6.23 and 2.2.5. Users are advised to upgrade. This vulnerability can be partially mitigated by removing `extras.view_dynamicgroup` permission from users however a full fix will require upgrading.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-280 (Improper Handling of Insufficient Permissions or Privileges)

## Which versions are affected by CVE-2024-36112?

5 open source packages ship an affected version, including nautobot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nautobot` | PyPI | From 1.3.0 | 1.6.23 |
| `nautobot` | PyPI | From 1.3.0 | 1.6.23 |
| `nautobot` | PyPI | From 2.0.0 | 2.2.5 |
| `nautobot` | PyPI | From 2.0.0 | 2.2.5 |
| `nautobot` | PyPI | From 2.0.0 | 2.3.0b1 |

Products: Networktocode Nautobot.

## How do I fix CVE-2024-36112?

Upgrade nautobot to a fixed version for your release line: 1.6.23, 2.2.5 or 2.3.0b1.

## Is CVE-2024-36112 being exploited?

There is no known exploitation of CVE-2024-36112 in the wild and no public exploit code.

## Other vulnerabilities in nautobot

- [CVE-2026-44797](https://insights.sbomify.com/CVE-2026-44797/): Nautobot: Webhook definitions could be used for server-side request forgery (SSRF) (high 8.5)
- [CVE-2024-34707](https://insights.sbomify.com/CVE-2024-34707/): Nautobot's BANNER_* configuration can be used to inject arbitrary HTML content into Nautobot pages (high 7.5)
- [CVE-2024-32979](https://insights.sbomify.com/CVE-2024-32979/): Reflected Cross-site Scripting potential in all object list views in Nautobot (high 7.5)
- [CVE-2023-25657](https://insights.sbomify.com/CVE-2023-25657/): Remote code execution in Jinja2 template rendering in Nautobot (high 7.5)
- [CVE-2026-44798](https://insights.sbomify.com/CVE-2026-44798/): Nautobot: GitRepository.current_head field should not be writable through REST API (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36112 and fix it if it is affected.

What it is: CVE-2024-36112 is a medium-severity missing authorization vulnerability in nautobot, published on 28 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36112 in the wild and no public exploit code.

Affected packages and fixed versions:
- nautobot (PyPI): affected from 1.3.0; fixed in 1.6.23
- nautobot (PyPI): affected from 1.3.0; fixed in 1.6.23
- nautobot (PyPI): affected from 2.0.0; fixed in 2.2.5
- nautobot (PyPI): affected from 2.0.0; fixed in 2.2.5
- nautobot (PyPI): affected from 2.0.0; fixed in 2.3.0b1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36112/ (Markdown: https://insights.sbomify.com/CVE-2024-36112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36112
- OSV: https://osv.dev/vulnerability/CVE-2024-36112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36112/
Summaries are generated and may contain mistakes; the official description above is the record.
