CVE-2024-36113 Discourse missing authorization checks for suspending admins/moderators

Medium 4.9 Published Updated

A rogue staff user can suspend other staff members, locking them out of the Discourse platform.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-36113?

CVE-2024-36113 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 3 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch, version 3.3.0.beta3 on the `beta` branch, and version 3.3.0.beta4-dev on the `tests-passed` branch, a rogue staff user could suspend other staff users preventing them from logging in to the site. The issue is patched in version 3.2.3 on the `stable` branch, version 3.3.0.beta3 on the `beta` branch, and version 3.3.0.beta4-dev on the `tests-passed` branch. No known workarounds are available.

Weakness: CWE-862

Which versions are affected by CVE-2024-36113?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.2.3

Products include Discourse Discourse.

How do I fix CVE-2024-36113?

Upgrade discourse to 3.2.3 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-36113 being exploited?

There is no known exploitation of CVE-2024-36113 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2024-36113, GHSA-3w3f-76p7-3c4g.

Is CVE-2024-36113 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free