# CVE-2024-36113: Discourse missing authorization checks for suspending admins/moderators

> A rogue staff user can suspend other staff members, locking them out of the Discourse platform.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-discourse-2024-36113, GHSA-3w3f-76p7-3c4g

## What is CVE-2024-36113?

CVE-2024-36113 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 3 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch, version 3.3.0.beta3 on the `beta` branch, and version 3.3.0.beta4-dev on the `tests-passed` branch, a rogue staff user could suspend other staff users preventing them from logging in to the site. The issue is patched in version 3.2.3 on the `stable` branch, version 3.3.0.beta3 on the `beta` branch, and version 3.3.0.beta4-dev on the `tests-passed` branch. No known workarounds are available.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-36113?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.2.3 |

Products: Discourse Discourse.

## How do I fix CVE-2024-36113?

Upgrade discourse to 3.2.3 or later.

## Is CVE-2024-36113 being exploited?

There is no known exploitation of CVE-2024-36113 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36113 and fix it if it is affected.

What it is: CVE-2024-36113 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 3 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36113 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36113/ (Markdown: https://insights.sbomify.com/CVE-2024-36113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36113
- OSV: https://osv.dev/vulnerability/CVE-2024-36113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36113/
Summaries are generated and may contain mistakes; the official description above is the record.
