# CVE-2024-36114: Decompressors can crash the JVM and leak memory content in Aircompressor

> Attackers can crash the JVM or leak sensitive memory by providing malicious compressed data to the Aircompressor library.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** CLSA-2026-1788349507, CLSA-2026-1788757894, CLSA-2026-1788757897, CLSA-2026-1788757903, ECHO-422f-d848-6aa6, GHSA-973x-65j7-xcf4, MINI-97w4-hqmh-pr72, MINI-r8q2-48fq-3f52

## What is CVE-2024-36114?

CVE-2024-36114 is a high-severity memory corruption vulnerability in airlift aircompressor, published on 29 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Aircompressor is a library with ports of the Snappy, LZO, LZ4, and Zstandard compression algorithms to Java. All decompressor implementations of Aircompressor (LZ4, LZO, Snappy, Zstandard) can crash the JVM for certain input, and in some cases also leak the content of other memory of the Java process (which could contain sensitive information). When decompressing certain data, the decompressors try to access memory outside the bounds of the given byte arrays or byte buffers. Because Aircompressor uses the JDK class `sun.misc.Unsafe` to speed up memory access, no additional bounds checks are performed and this has similar security consequences as out-of-bounds access in C or C++, namely it can lead to non-deterministic behavior or crash the JVM. Users should update to Aircompressor 0.27 or newer where these issues have been fixed. When decompressing data from untrusted users, this can be exploited for a denial-of-service attack by crashing the JVM, or to leak other sensitive information from the Java process. There are no known workarounds for this issue.

Weakness: CWE-787 (Out-of-bounds Write), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2024-36114?

2 open source packages ship an affected version, including io.airlift:aircompressor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.airlift:aircompressor` | Maven | All versions | 0.27 |
| `io.airlift:aircompressor` | Maven | All versions | 0.27 |

## How do I fix CVE-2024-36114?

Upgrade io.airlift:aircompressor to 0.27 or later.

## Is CVE-2024-36114 being exploited?

There is no known exploitation of CVE-2024-36114 in the wild and no public exploit code.

Public exploit code:

- Serpstat fork of housepower/ClickHouse-Native-JDBC 2.7.1. Fixes the CityHash128 checksum defect behind "Checksum doesn't match: corrupted data" on INSERT, upgrades aircompressor to 0.27 (CVE-2024-36114). Drop-in: com.serpstat:clickhouse-native-jdbc-shaded:2.7.1-serpstat.1. Apache 2.0. (github_poc): https://github.com/SerpstatGlobal/ClickHouse-Native-JDBC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36114 and fix it if it is affected.

What it is: CVE-2024-36114 is a high-severity memory corruption vulnerability in airlift aircompressor, published on 29 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36114 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.airlift:aircompressor (Maven): affected all versions; fixed in 0.27
- io.airlift:aircompressor (Maven): affected all versions; fixed in 0.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36114/ (Markdown: https://insights.sbomify.com/CVE-2024-36114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36114
- OSV: https://osv.dev/vulnerability/CVE-2024-36114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36114/
Summaries are generated and may contain mistakes; the official description above is the record.
