{"answers":{"affected":"2 open source packages ship an affected version, including js-deobfuscator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-36120 in the wild and no public exploit code.","fix":"Upgrade js-deobfuscator to 1.1.0 or later.","what":"CVE-2024-36120 is a high-severity code injection vulnerability in ben-sb javascript-deobfuscator, published on 31 May 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-36120 and fix it if it is affected.\n\nWhat it is: CVE-2024-36120 is a high-severity code injection vulnerability in ben-sb javascript-deobfuscator, published on 31 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-36120 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- js-deobfuscator (npm): affected all versions; fixed in 1.1.0\n- js-deobfuscator (npm): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-36120/ (Markdown: https://insights.sbomify.com/CVE-2024-36120/index.md)","id":"CVE-2024-36120","markdown":"https://insights.sbomify.com/CVE-2024-36120/index.md","name":"CVE-2024-36120","record":{"aliases":["GHSA-9p6p-8v9r-8c9m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"JavaScript deobfuscation library","requires_auth":"none","summary":"Attackers can execute arbitrary code via crafted payloads in the javascript-deobfuscator library, requiring users to upgrade or disable expression simplification.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"javascript_deobfuscator","vendor":"deobfuscate"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"javascript-deobfuscator removes common JavaScript obfuscation techniques. In affected versions crafted payloads targeting expression simplification can lead to code execution. This issue has been patched in version 1.1.0. Users are advised to update. Users unable to upgrade should disable the expression simplification feature.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"javascript-deobfuscator crafted payload can lead to code execution","id":"CVE-2024-36120","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"netty-incubator-codec-ohttp's BoringSSLAEADContext Repeats Nonces","id":"CVE-2024-36121"},"packages":[{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"js-deobfuscator","purl":null,"source":"GHSA-9p6p-8v9r-8c9m"},{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"js-deobfuscator","purl":"pkg:npm/js-deobfuscator","source":"GHSA-9p6p-8v9r-8c9m"}],"prev":{"headline":"Password confirmation stored in plain text via registration form in statamic/cms","id":"CVE-2024-36119"},"products":["javascript-deobfuscator"],"published":"2024-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["ben-sb"]},"summary":"Attackers can execute arbitrary code via crafted payloads in the javascript-deobfuscator library, requiring users to upgrade or disable expression simplification.","url":"https://insights.sbomify.com/CVE-2024-36120/"}