# CVE-2024-36120: javascript-deobfuscator crafted payload can lead to code execution

> Attackers can execute arbitrary code via crafted payloads in the javascript-deobfuscator library, requiring users to upgrade or disable expression simplification.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-9p6p-8v9r-8c9m

## What is CVE-2024-36120?

CVE-2024-36120 is a high-severity code injection vulnerability in ben-sb javascript-deobfuscator, published on 31 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

javascript-deobfuscator removes common JavaScript obfuscation techniques. In affected versions crafted payloads targeting expression simplification can lead to code execution. This issue has been patched in version 1.1.0. Users are advised to update. Users unable to upgrade should disable the expression simplification feature.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-36120?

2 open source packages ship an affected version, including js-deobfuscator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `js-deobfuscator` | npm | All versions | 1.1.0 |
| `js-deobfuscator` | npm | All versions | 1.1.0 |

Products: Deobfuscate Javascript Deobfuscator.

## How do I fix CVE-2024-36120?

Upgrade js-deobfuscator to 1.1.0 or later.

## Is CVE-2024-36120 being exploited?

There is no known exploitation of CVE-2024-36120 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36120 and fix it if it is affected.

What it is: CVE-2024-36120 is a high-severity code injection vulnerability in ben-sb javascript-deobfuscator, published on 31 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36120 in the wild and no public exploit code.

Affected packages and fixed versions:
- js-deobfuscator (npm): affected all versions; fixed in 1.1.0
- js-deobfuscator (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36120/ (Markdown: https://insights.sbomify.com/CVE-2024-36120/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36120
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36120
- OSV: https://osv.dev/vulnerability/CVE-2024-36120

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36120/
Summaries are generated and may contain mistakes; the official description above is the record.
