# CVE-2024-36123: Citizen has a Stored Cross-Site Scripting Vulnerability by editing MediaWiki:Tagline

> Attackers with interface editing permissions can inject malicious scripts via the Tagline page, leading to XSS attacks against other users.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-jhm6-qjhq-5mf9, UBUNTU-CVE-2024-36123

## What is CVE-2024-36123?

CVE-2024-36123 is a medium-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 3 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. The page `MediaWiki:Tagline` has its contents used unescaped, so custom HTML (including Javascript) can be injected by someone with the ability to edit the MediaWiki namespace (typically those with the `editinterface` permission, or sysops). This vulnerability is fixed in 2.16.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-36123?

It affects 1 product.


Products: Starcitizen.tools Citizen.

## How do I fix CVE-2024-36123?

No fix has been published for CVE-2024-36123 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-36123 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36123 exists.

## Other vulnerabilities in StarCitizenTools mediawiki-skins-Citizen

- [CVE-2025-53368](https://insights.sbomify.com/CVE-2025-53368/): Citizen is vulnerable to stored XSS attack in the legacy search bar (high 8.6)
- [CVE-2025-53370](https://insights.sbomify.com/CVE-2025-53370/): Citizen stored XSS vulnerability through short descriptions (high 8.6)
- [CVE-2025-49575](https://insights.sbomify.com/CVE-2025-49575/): Citizen allows stored XSS in Command Palette tip messages (medium 6.5)
- [CVE-2025-49576](https://insights.sbomify.com/CVE-2025-49576/): Citizen allows stored XSS in search no result messages (medium 6.5)
- [CVE-2025-49577](https://insights.sbomify.com/CVE-2025-49577/): Citizen allows stored XSS in preference menu headings (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36123 and fix it if it is affected.

What it is: CVE-2024-36123 is a medium-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 3 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36123 exists.

Affected product: StarCitizenTools mediawiki-skins-Citizen. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36123/ (Markdown: https://insights.sbomify.com/CVE-2024-36123/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36123
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36123
- OSV: https://osv.dev/vulnerability/CVE-2024-36123

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36123/
Summaries are generated and may contain mistakes; the official description above is the record.
