{"answers":{"affected":"2 open source packages ship an affected version, including org.iq80.snappy:snappy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-36124 in the wild and no public exploit code.","fix":"Upgrade org.iq80.snappy:snappy to 0.5 or later.","what":"CVE-2024-36124 is a medium-severity memory corruption vulnerability in dain snappy, published on 3 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-36124 and fix it if it is affected.\n\nWhat it is: CVE-2024-36124 is a medium-severity memory corruption vulnerability in dain snappy, published on 3 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-36124 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.iq80.snappy:snappy (Maven): affected all versions; fixed in 0.5\n- org.iq80.snappy:snappy (Maven): affected all versions; fixed in 0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-36124/ (Markdown: https://insights.sbomify.com/CVE-2024-36124/index.md)","id":"CVE-2024-36124","markdown":"https://insights.sbomify.com/CVE-2024-36124/index.md","name":"CVE-2024-36124","record":{"aliases":["GHSA-8wh2-6qhj-h7j9","ROOT-APP-MAVEN-CVE-2024-36124"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java compression library","requires_auth":"none","summary":"Attackers can crash the JVM by providing malicious compressed data to the iq80 Snappy library due to an out-of-bounds read vulnerability.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"snappy","vendor":"dain"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"iq80 Snappy is a compression/decompression library. When uncompressing certain data, Snappy tries to read outside the bounds of the given byte arrays. Because Snappy uses the JDK class `sun.misc.Unsafe` to speed up memory access, no additional bounds checks are performed and this has similar security consequences as out-of-bounds access in C or C++, namely it can lead to non-deterministic behavior or crash the JVM. iq80 Snappy is not actively maintained anymore. As quick fix users can upgrade to version 0.5.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"iq80 Snappy has an out-of-bounds read when uncompressing data, leading to JVM crash","id":"CVE-2024-36124","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"apko Exposure of HTTP basic auth credentials in log output","id":"CVE-2024-36127"},"packages":[{"ecosystem":"Maven","fixed":["0.5"],"introduced":["0"],"last_affected":[],"package":"org.iq80.snappy:snappy","purl":null,"source":"GHSA-8wh2-6qhj-h7j9"},{"ecosystem":"Maven","fixed":["0.5"],"introduced":["0"],"last_affected":[],"package":"org.iq80.snappy:snappy","purl":"pkg:maven/org.iq80.snappy/snappy","source":"GHSA-8wh2-6qhj-h7j9"}],"prev":{"headline":"Citizen has a Stored Cross-Site Scripting Vulnerability by editing MediaWiki:Tagline","id":"CVE-2024-36123"},"products":["snappy"],"published":"2024-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-05","vendors":["dain"]},"summary":"Attackers can crash the JVM by providing malicious compressed data to the iq80 Snappy library due to an out-of-bounds read vulnerability.","url":"https://insights.sbomify.com/CVE-2024-36124/"}