{"answers":{"affected":"3 open source packages ship an affected version, including chainguard.dev/apko.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36127 exists.","fix":"Upgrade chainguard.dev/apko to 0.14.5 or later.","what":"CVE-2024-36127 is a high-severity vulnerability in chainguard-dev apko, published on 3 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-36127 and fix it if it is affected.\n\nWhat it is: CVE-2024-36127 is a high-severity vulnerability in chainguard-dev apko, published on 3 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36127 exists.\n\nAffected packages and fixed versions:\n- chainguard.dev/apko (Go): affected all versions; fixed in 0.14.5\n- chainguard.dev/apko (Go): affected all versions; fixed in 0.14.5\n- chainguard.dev/apko (Go): affected all versions; fixed in 0.14.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-36127/ (Markdown: https://insights.sbomify.com/CVE-2024-36127/index.md)","id":"CVE-2024-36127","markdown":"https://insights.sbomify.com/CVE-2024-36127/index.md","name":"CVE-2024-36127","record":{"aliases":["GHSA-v6mg-7f7p-qmqp","GO-2024-2899"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"OCI image builder","requires_auth":"none","summary":"Attackers can view exposed HTTP basic auth credentials in log output from the apko OCI image builder.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"},{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"apko is an apk-based OCI image builder. apko exposures HTTP basic auth credentials from repository and keyring URLs in log output. This vulnerability is fixed in v0.14.5.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"apko Exposure of HTTP basic auth credentials in log output","id":"CVE-2024-36127","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Directus is soft-locked by providing a string value to random string util","id":"CVE-2024-36128"},"packages":[{"ecosystem":"Go","fixed":["0.14.5"],"introduced":["0"],"last_affected":[],"package":"chainguard.dev/apko","purl":null,"source":"GHSA-v6mg-7f7p-qmqp"},{"ecosystem":"Go","fixed":["0.14.5"],"introduced":["0"],"last_affected":[],"package":"chainguard.dev/apko","purl":"pkg:golang/chainguard.dev/apko","source":"GHSA-v6mg-7f7p-qmqp"},{"ecosystem":"Go","fixed":["0.14.5"],"introduced":["0"],"last_affected":[],"package":"chainguard.dev/apko","purl":"pkg:golang/chainguard.dev/apko","source":"GO-2024-2899"}],"prev":{"headline":"iq80 Snappy has an out-of-bounds read when uncompressing data, leading to JVM crash","id":"CVE-2024-36124"},"products":["apko"],"published":"2024-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-03","vendors":["chainguard-dev"]},"summary":"Attackers can view exposed HTTP basic auth credentials in log output from the apko OCI image builder.","url":"https://insights.sbomify.com/CVE-2024-36127/"}