# CVE-2024-36127: apko Exposure of HTTP basic auth credentials in log output

> Attackers can view exposed HTTP basic auth credentials in log output from the apko OCI image builder.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2024
- **Updated:** 3 Sep 2024
- **Also known as:** GHSA-v6mg-7f7p-qmqp, GO-2024-2899

## What is CVE-2024-36127?

CVE-2024-36127 is a high-severity vulnerability in chainguard-dev apko, published on 3 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

apko is an apk-based OCI image builder. apko exposures HTTP basic auth credentials from repository and keyring URLs in log output. This vulnerability is fixed in v0.14.5.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2024-36127?

3 open source packages ship an affected version, including chainguard.dev/apko.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainguard.dev/apko` | Go | All versions | 0.14.5 |
| `chainguard.dev/apko` | Go | All versions | 0.14.5 |
| `chainguard.dev/apko` | Go | All versions | 0.14.5 |

## How do I fix CVE-2024-36127?

Upgrade chainguard.dev/apko to 0.14.5 or later.

## Is CVE-2024-36127 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36127 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36127 and fix it if it is affected.

What it is: CVE-2024-36127 is a high-severity vulnerability in chainguard-dev apko, published on 3 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36127 exists.

Affected packages and fixed versions:
- chainguard.dev/apko (Go): affected all versions; fixed in 0.14.5
- chainguard.dev/apko (Go): affected all versions; fixed in 0.14.5
- chainguard.dev/apko (Go): affected all versions; fixed in 0.14.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36127/ (Markdown: https://insights.sbomify.com/CVE-2024-36127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36127
- OSV: https://osv.dev/vulnerability/CVE-2024-36127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36127/
Summaries are generated and may contain mistakes; the official description above is the record.
