CVE-2024-36129 OpenTelemetry Collector has a Denial of Service via Zip/Decompression Bomb sent over HTTP or gRPC

High 8.2 Published Updated

Unauthenticated attackers can crash the OpenTelemetry Collector by sending zip or decompression bombs over HTTP or gRPC, causing excessive memory consumption.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-36129?

CVE-2024-36129 is a high-severity denial of service vulnerability in open-telemetry opentelemetry-collector, published on 5 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The OpenTelemetry Collector offers a vendor-agnostic implementation on how to receive, process and export telemetry data. An unsafe decompression vulnerability allows unauthenticated attackers to crash the collector via excessive memory consumption. OTel Collector version 0.102.1 fixes this issue. It is also fixed in the confighttp module version 0.102.0 and configgrpc module version 0.102.1.

Weakness: CWE-119

Which versions are affected by CVE-2024-36129?

7 open source packages ship an affected version, including opentelemetry-collector, go.opentelemetry.io/collector/config/configgrpc and go.opentelemetry.io/collector/config/confighttp. It affects 3 products.

PackageAffectedFixed in
opentelemetry-collector BitnamiAll versions0.102.1
go.opentelemetry.io/collector/config/configgrpc GoAll versions0.102.1
go.opentelemetry.io/collector/config/configgrpc GoAll versions0.102.1
go.opentelemetry.io/collector/config/configgrpc GoAll versions0.102.1
go.opentelemetry.io/collector/config/confighttp GoAll versions0.102.0
go.opentelemetry.io/collector/config/confighttp GoAll versions0.102.0
1 more packages
go.opentelemetry.io/collector/config/confighttp GoAll versions0.102.0

Products include Opentelemetry Configgrpc, Opentelemetry Confighttp, Opentelemetry Opentelemetry Collector.

How do I fix CVE-2024-36129?

Upgrade opentelemetry-collector to 0.102.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-36129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36129 exists.

Sources

Also known as BIT-opentelemetry-collector-2024-36129, GHSA-c74f-6mfw-mm4v, GO-2024-2900.

Is CVE-2024-36129 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free