# CVE-2024-36129: OpenTelemetry Collector has a Denial of Service via Zip/Decompression Bomb sent over HTTP or gRPC

> Unauthenticated attackers can crash the OpenTelemetry Collector by sending zip or decompression bombs over HTTP or gRPC, causing excessive memory consumption.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-opentelemetry-collector-2024-36129, GHSA-c74f-6mfw-mm4v, GO-2024-2900

## What is CVE-2024-36129?

CVE-2024-36129 is a high-severity denial of service vulnerability in open-telemetry opentelemetry-collector, published on 5 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The OpenTelemetry Collector offers a vendor-agnostic implementation on how to receive, process and export telemetry data. An unsafe decompression vulnerability allows unauthenticated attackers to crash the collector via excessive memory consumption. OTel Collector version 0.102.1 fixes this issue.  It is also fixed in the confighttp module version 0.102.0 and configgrpc module version 0.102.1.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2024-36129?

7 open source packages ship an affected version, including opentelemetry-collector, go.opentelemetry.io/collector/config/configgrpc and go.opentelemetry.io/collector/config/confighttp. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opentelemetry-collector` | Bitnami | All versions | 0.102.1 |
| `go.opentelemetry.io/collector/config/configgrpc` | Go | All versions | 0.102.1 |
| `go.opentelemetry.io/collector/config/configgrpc` | Go | All versions | 0.102.1 |
| `go.opentelemetry.io/collector/config/configgrpc` | Go | All versions | 0.102.1 |
| `go.opentelemetry.io/collector/config/confighttp` | Go | All versions | 0.102.0 |
| `go.opentelemetry.io/collector/config/confighttp` | Go | All versions | 0.102.0 |
| `go.opentelemetry.io/collector/config/confighttp` | Go | All versions | 0.102.0 |

Products: Opentelemetry Configgrpc, Opentelemetry Confighttp, Opentelemetry Opentelemetry Collector.

## How do I fix CVE-2024-36129?

Upgrade opentelemetry-collector to 0.102.1 or later.

## Is CVE-2024-36129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36129 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36129 and fix it if it is affected.

What it is: CVE-2024-36129 is a high-severity denial of service vulnerability in open-telemetry opentelemetry-collector, published on 5 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36129 exists.

Affected packages and fixed versions:
- opentelemetry-collector (Bitnami): affected all versions; fixed in 0.102.1
- go.opentelemetry.io/collector/config/configgrpc (Go): affected all versions; fixed in 0.102.1
- go.opentelemetry.io/collector/config/configgrpc (Go): affected all versions; fixed in 0.102.1
- go.opentelemetry.io/collector/config/configgrpc (Go): affected all versions; fixed in 0.102.1
- go.opentelemetry.io/collector/config/confighttp (Go): affected all versions; fixed in 0.102.0
- go.opentelemetry.io/collector/config/confighttp (Go): affected all versions; fixed in 0.102.0
- go.opentelemetry.io/collector/config/confighttp (Go): affected all versions; fixed in 0.102.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36129/ (Markdown: https://insights.sbomify.com/CVE-2024-36129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36129
- OSV: https://osv.dev/vulnerability/CVE-2024-36129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36129/
Summaries are generated and may contain mistakes; the official description above is the record.
