CVE-2024-36250 MFA Code Replay

Low 3.1 Published Updated

Attackers can bypass multi-factor authentication by replaying valid codes within a short window, leading to unauthorized account access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-36250?

CVE-2024-36250 is a low-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 9 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 9.11.x <= 9.11.2, and 9.5.x <= 9.5.10 fail to protect the mfa code against replay attacks, which allows an attacker to reuse the MFA code within ~30 seconds

Weakness: CWE-294, CWE-303

Which versions are affected by CVE-2024-36250?

1 open source package ship an affected version, including mattermost. It affects 1 product.

PackageAffectedFixed in
mattermost BitnamiFrom 9.5.09.5.11, 9.11.3

Products include Mattermost Mattermost Server.

How do I fix CVE-2024-36250?

Upgrade mattermost to a fixed version for your release line: 9.5.11 or 9.11.3.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-36250 being exploited?

There is no known exploitation of CVE-2024-36250 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as BIT-mattermost-2024-36250, GHSA-8ww9-xwc2-p9cc.

Is CVE-2024-36250 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free