# CVE-2024-36259: Information disclosure in Odoo Community

> Remote authenticated attackers can extract sensitive information from the mail module via an oracle-based attack in Odoo.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2025
- **Updated:** 25 Feb 2025
- **Also known as:** BIT-odoo-2024-36259, GHSA-x3g3-3qwm-w95x, UBUNTU-CVE-2024-36259

## What is CVE-2024-36259?

CVE-2024-36259 is a high-severity vulnerability in Odoo Odoo, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper access control in mail module of Odoo Community 17.0 and Odoo Enterprise 17.0 allows remote authenticated attackers to extract sensitive information via an oracle-based (yes/no response) crafted attack.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-36259?

1 open source package ship an affected version, including odoo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `odoo` | Bitnami | From 17.0.0 | 17.0.20240505 |

Products: Odoo Odoo.

## How do I fix CVE-2024-36259?

Upgrade odoo to 17.0.20240505 or later.

## Is CVE-2024-36259 being exploited?

There is no known exploitation of CVE-2024-36259 in the wild and no public exploit code.

## Other vulnerabilities in Odoo Odoo

- [CVE-2020-29396](https://insights.sbomify.com/CVE-2020-29396/): Code injection in Odoo Community (critical 9.9)
- [CVE-2018-14885](https://insights.sbomify.com/CVE-2018-14885/): Auth bypass in n/a (critical 9.8)
- [CVE-2017-10804](https://insights.sbomify.com/CVE-2017-10804/): Auth bypass in n/a (critical 9.8)
- [CVE-2018-14860](https://insights.sbomify.com/CVE-2018-14860/): Code injection in n/a (critical 9.1)
- [CVE-2017-10805](https://insights.sbomify.com/CVE-2017-10805/): Auth bypass in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36259 and fix it if it is affected.

What it is: CVE-2024-36259 is a high-severity vulnerability in Odoo Odoo, published on 25 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36259 in the wild and no public exploit code.

Affected packages and fixed versions:
- odoo (Bitnami): affected from 17.0.0; fixed in 17.0.20240505

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36259/ (Markdown: https://insights.sbomify.com/CVE-2024-36259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36259
- OSV: https://osv.dev/vulnerability/CVE-2024-36259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36259/
Summaries are generated and may contain mistakes; the official description above is the record.
