CVE-2024-36268 Apache InLong TubeMQ Client: Remote Code Execution vulnerability

High 7.6 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-36268?

CVE-2024-36268 is a high-severity vulnerability in Apache InLong TubeMQ Client, published on 2 Aug 2024.

Official description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong.

This issue affects Apache InLong: from 1.10.0 through 1.12.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.13.0 or cherry-pick [1] to solve it.

[1]  https://github.com/apache/inlong/pull/10251

Weakness: CWE-94

Which versions are affected by CVE-2024-36268?

2 open source packages ship an affected version, including org.apache.inlong:tubemq-core. It affects 1 product.

PackageAffectedFixed in
org.apache.inlong:tubemq-core MavenFrom 1.10.01.13.0
org.apache.inlong:tubemq-core MavenFrom 1.10.01.13.0

Products include Apache Inlong.

How do I fix CVE-2024-36268?

Upgrade org.apache.inlong:tubemq-core to 1.13.0 or later.

Is CVE-2024-36268 being exploited?

There is no known exploitation of CVE-2024-36268 in the wild and no public exploit code.

Sources

Also known as GHSA-qff2-8qw7-hcvw.

Is CVE-2024-36268 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free