# CVE-2024-36268: Apache InLong TubeMQ Client: Remote Code Execution vulnerability


- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 2 Aug 2024
- **Updated:** 22 Aug 2024
- **Also known as:** GHSA-qff2-8qw7-hcvw

## What is CVE-2024-36268?

CVE-2024-36268 is a high-severity vulnerability in Apache InLong TubeMQ Client, published on 2 Aug 2024. 

### Official description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong.

This issue affects Apache InLong: from 1.10.0 through 1.12.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.13.0 or cherry-pick [1] to solve it.

[1]  https://github.com/apache/inlong/pull/10251

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-36268?

2 open source packages ship an affected version, including org.apache.inlong:tubemq-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.inlong:tubemq-core` | Maven | From 1.10.0 | 1.13.0 |
| `org.apache.inlong:tubemq-core` | Maven | From 1.10.0 | 1.13.0 |

Products: Apache Inlong.

## How do I fix CVE-2024-36268?

Upgrade org.apache.inlong:tubemq-core to 1.13.0 or later.

## Is CVE-2024-36268 being exploited?

There is no known exploitation of CVE-2024-36268 in the wild and no public exploit code.

## Other vulnerabilities in Apache InLong TubeMQ Client

- [CVE-2026-63037](https://insights.sbomify.com/CVE-2026-63037/): Apache InLong: Unauthenticated SQL injection in Manager OpenAPI audit alert rule list endpoint (critical 9.8)
- [CVE-2026-63038](https://insights.sbomify.com/CVE-2026-63038/): Apache InLong: SQL Injection via String Concatenation Vulnerability Report (critical 9.8)
- [CVE-2026-63039](https://insights.sbomify.com/CVE-2026-63039/): Apache InLong: SQL Injection via Unvalidated MyBatis Dollar-Sign Interpolation in AuditAlertRuleService (critical 9.8)
- [CVE-2025-27531](https://insights.sbomify.com/CVE-2025-27531/): Apache InLong: An arbitrary file read vulnerability for JDBC (critical 9.8)
- [CVE-2024-26579](https://insights.sbomify.com/CVE-2024-26579/): Apache Inlong JDBC Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36268 and fix it if it is affected.

What it is: CVE-2024-36268 is a high-severity vulnerability in Apache InLong TubeMQ Client, published on 2 Aug 2024. 
Exploitation: There is no known exploitation of CVE-2024-36268 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.inlong:tubemq-core (Maven): affected from 1.10.0; fixed in 1.13.0
- org.apache.inlong:tubemq-core (Maven): affected from 1.10.0; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36268/ (Markdown: https://insights.sbomify.com/CVE-2024-36268/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36268
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36268
- OSV: https://osv.dev/vulnerability/CVE-2024-36268

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36268/
Summaries are generated and may contain mistakes; the official description above is the record.
