{"answers":{"affected":"4 open source packages ship an affected version, including pug and pug-code-gen.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36361 exists.","fix":"Upgrade pug to 3.0.3 or later.","what":"CVE-2024-36361 is a medium-severity code injection vulnerability in n/a, published on 24 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-36361 and fix it if it is affected.\n\nWhat it is: CVE-2024-36361 is a medium-severity code injection vulnerability in n/a, published on 24 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36361 exists.\n\nAffected packages and fixed versions:\n- pug (npm): affected all versions; fixed in 3.0.3\n- pug (npm): affected all versions; fixed in 3.0.3\n- pug-code-gen (npm): affected all versions; fixed in 3.0.3\n- pug-code-gen (npm): affected all versions; fixed in 3.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-36361/ (Markdown: https://insights.sbomify.com/CVE-2024-36361/index.md)","id":"CVE-2024-36361","markdown":"https://insights.sbomify.com/CVE-2024-36361/index.md","name":"CVE-2024-36361","record":{"aliases":["CLSA-2026-1786620685","GHSA-3965-hpx2-q597","ROOT-APP-NPM-CVE-2024-36361"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Pug template engine","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript if untrusted input is passed to specific Pug compilation functions, requiring developers to avoid such usage.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":6.8,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Pug through 3.0.2 allows JavaScript code execution if an application accepts untrusted input for the name option of the compileClient, compileFileClient, or compileClientWithDependenciesTracked function. NOTE: these functions are for compiling Pug templates into JavaScript, and there would typically be no reason to allow untrusted callers.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Pug allows JavaScript code execution if an application accepts untrusted input","id":"CVE-2024-36361","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":4,"n_references":2,"next":{"headline":"Path traversal in TeamCity","id":"CVE-2024-36362"},"packages":[{"ecosystem":"npm","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"pug","purl":null,"source":"GHSA-3965-hpx2-q597"},{"ecosystem":"npm","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"pug","purl":"pkg:npm/pug","source":"GHSA-3965-hpx2-q597"},{"ecosystem":"npm","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"pug-code-gen","purl":null,"source":"GHSA-3965-hpx2-q597"},{"ecosystem":"npm","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"pug-code-gen","purl":"pkg:npm/pug-code-gen","source":"GHSA-3965-hpx2-q597"}],"prev":{"headline":"Command injection in awkblog","id":"CVE-2024-36360"},"products":["n/a"],"published":"2024-05-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["n/a"]},"summary":"Attackers can execute arbitrary JavaScript if untrusted input is passed to specific Pug compilation functions, requiring developers to avoid such usage.","url":"https://insights.sbomify.com/CVE-2024-36361/"}