# CVE-2024-36361: Pug allows JavaScript code execution if an application accepts untrusted input

> Attackers can execute arbitrary JavaScript if untrusted input is passed to specific Pug compilation functions, requiring developers to avoid such usage.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** CLSA-2026-1786620685, GHSA-3965-hpx2-q597, ROOT-APP-NPM-CVE-2024-36361

## What is CVE-2024-36361?

CVE-2024-36361 is a medium-severity code injection vulnerability in n/a, published on 24 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pug through 3.0.2 allows JavaScript code execution if an application accepts untrusted input for the name option of the compileClient, compileFileClient, or compileClientWithDependenciesTracked function. NOTE: these functions are for compiling Pug templates into JavaScript, and there would typically be no reason to allow untrusted callers.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-36361?

4 open source packages ship an affected version, including pug and pug-code-gen.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pug` | npm | All versions | 3.0.3 |
| `pug` | npm | All versions | 3.0.3 |
| `pug-code-gen` | npm | All versions | 3.0.3 |
| `pug-code-gen` | npm | All versions | 3.0.3 |

## How do I fix CVE-2024-36361?

Upgrade pug to 3.0.3 or later.

## Is CVE-2024-36361 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36361 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36361 and fix it if it is affected.

What it is: CVE-2024-36361 is a medium-severity code injection vulnerability in n/a, published on 24 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36361 exists.

Affected packages and fixed versions:
- pug (npm): affected all versions; fixed in 3.0.3
- pug (npm): affected all versions; fixed in 3.0.3
- pug-code-gen (npm): affected all versions; fixed in 3.0.3
- pug-code-gen (npm): affected all versions; fixed in 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36361/ (Markdown: https://insights.sbomify.com/CVE-2024-36361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36361
- OSV: https://osv.dev/vulnerability/CVE-2024-36361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36361/
Summaries are generated and may contain mistakes; the official description above is the record.
