{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-36387 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.60 or later.","what":"CVE-2024-36387 is a medium-severity vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-36387 and fix it if it is affected.\n\nWhat it is: CVE-2024-36387 is a medium-severity vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-36387 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.55; fixed in 2.4.60\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-36387/ (Markdown: https://insights.sbomify.com/CVE-2024-36387/index.md)","id":"CVE-2024-36387","markdown":"https://insights.sbomify.com/CVE-2024-36387/index.md","name":"CVE-2024-36387","record":{"aliases":["ALPINE-CVE-2024-36387","ALSA-2024:8680","AZL-43089","AZL-43119","BELL-CVE-2024-36387","BIT-apache-2024-36387","CLEANSTART-2026-OA48166","DEBIAN-CVE-2024-36387","GHSA-463r-p989-2f9j","OESA-2024-1847","RHSA-2024:8680","RLSA-2024:8680","UBUNTU-CVE-2024-36387"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache HTTP Server","requires_auth":"low_privilege","summary":"A null pointer dereference in Apache HTTP Server when serving WebSocket upgrades over HTTP/2 causes a server crash, leading to denial of service.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"},{"product":"ontap","vendor":"netapp"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-476","name":"NULL Pointer Dereference"}],"description":"Serving WebSocket protocol upgrades over a HTTP/2 connection could result in a Null Pointer dereference, leading to a crash of the server process, degrading performance.","ecosystems":["AlmaLinux:9","Bitnami","Red Hat:enterprise_linux:9::appstream","Rocky Linux:9"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache HTTP Server: DoS by Null pointer in websocket over HTTP/2","id":"CVE-2024-36387","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server"],"type":"null_dereference","year":"2024"},"n_packages":6,"n_references":2,"next":{"headline":"MileSight DeviceHub - CWE-305 Missing Authentication for Critical Function","id":"CVE-2024-36388"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.60"],"introduced":["2.4.55"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2024-36387"},{"ecosystem":"AlmaLinux:9","fixed":["2.0.26-2.el9_4.1"],"introduced":["0"],"last_affected":[],"package":"mod_http2","purl":"pkg:rpm/almalinux/mod_http2","source":"ALSA-2024:8680"},{"ecosystem":"Red Hat:enterprise_linux:9::appstream","fixed":["0:2.0.26-2.el9_4.1"],"introduced":["0"],"last_affected":[],"package":"mod_http2","purl":"pkg:rpm/redhat/mod_http2","source":"RHSA-2024:8680"},{"ecosystem":"Red Hat:enterprise_linux:9::appstream","fixed":["0:2.0.26-2.el9_4.1"],"introduced":["0"],"last_affected":[],"package":"mod_http2-debuginfo","purl":"pkg:rpm/redhat/mod_http2-debuginfo","source":"RHSA-2024:8680"},{"ecosystem":"Red Hat:enterprise_linux:9::appstream","fixed":["0:2.0.26-2.el9_4.1"],"introduced":["0"],"last_affected":[],"package":"mod_http2-debugsource","purl":"pkg:rpm/redhat/mod_http2-debugsource","source":"RHSA-2024:8680"},{"ecosystem":"Rocky Linux:9","fixed":["0:2.0.26-2.el9_4.1"],"introduced":["0"],"last_affected":[],"package":"mod_http2","purl":"pkg:rpm/rocky-linux/mod_http2?distro=rocky-linux-9\u0026epoch=0","source":"RLSA-2024:8680"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-36384"},"products":["Apache HTTP Server"],"published":"2024-07-01","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"MIT","name":"AlmaLinux","prefix":"ALSA"},{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"BSD","name":"Rocky Linux","prefix":"RLSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"A null pointer dereference in Apache HTTP Server when serving WebSocket upgrades over HTTP/2 causes a server crash, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2024-36387/"}