# CVE-2024-36387: Apache HTTP Server: DoS by Null pointer in websocket over HTTP/2

> A null pointer dereference in Apache HTTP Server when serving WebSocket upgrades over HTTP/2 causes a server crash, leading to denial of service.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2024
- **Updated:** 13 Feb 2025
- **Also known as:** ALPINE-CVE-2024-36387, ALSA-2024:8680, AZL-43089, AZL-43119, BELL-CVE-2024-36387, BIT-apache-2024-36387, CLEANSTART-2026-OA48166, DEBIAN-CVE-2024-36387, GHSA-463r-p989-2f9j, OESA-2024-1847, RHSA-2024:8680, RLSA-2024:8680, UBUNTU-CVE-2024-36387

## What is CVE-2024-36387?

CVE-2024-36387 is a medium-severity vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Serving WebSocket protocol upgrades over a HTTP/2 connection could result in a Null Pointer dereference, leading to a crash of the server process, degrading performance.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2024-36387?

1 open source package ship an affected version, including apache. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.55 | 2.4.60 |
| `mod_http2` | AlmaLinux:9 | All versions | 2.0.26-2.el9_4.1 |
| `mod_http2` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-2.el9_4.1 |
| `mod_http2-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-2.el9_4.1 |
| `mod_http2-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-2.el9_4.1 |
| `mod_http2` | Rocky Linux:9 | All versions | 0:2.0.26-2.el9_4.1 |

Products: Apache Http Server, Netapp Ontap.

## How do I fix CVE-2024-36387?

Upgrade apache to 2.4.60 or later.

## Is CVE-2024-36387 being exploited?

There is no known exploitation of CVE-2024-36387 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36387 and fix it if it is affected.

What it is: CVE-2024-36387 is a medium-severity vulnerability in Apache Http Server, published on 1 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36387 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.55; fixed in 2.4.60

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36387/ (Markdown: https://insights.sbomify.com/CVE-2024-36387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36387
- OSV: https://osv.dev/vulnerability/CVE-2024-36387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36387/
Summaries are generated and may contain mistakes; the official description above is the record.
