CVE-2024-36414 SuiteCRM authenticated Server-Side Request Forgery

High 7.7 Published Updated

Authenticated attackers can exploit a flaw in SuiteCRM's connector file verification to perform server-side request forgery attacks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-36414?

CVE-2024-36414 is a high-severity server-side request forgery vulnerability in Salesagility Suitecrm, published on 10 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

SuiteCRM is an open-source Customer Relationship Management (CRM) software application. Prior to versions 7.14.4 and 8.6.1, a vulnerability in the connectors file verification allows for a server-side request forgery attack. Versions 7.14.4 and 8.6.1 contain a fix for this issue.

Weakness: CWE-918

Which versions are affected by CVE-2024-36414?

1 open source package ship an affected version, including suitecrm. It affects 1 product.

PackageAffectedFixed in
suitecrm BitnamiAll versions7.14.4, 8.6.1

Products include Salesagility Suitecrm.

How do I fix CVE-2024-36414?

Upgrade suitecrm to a fixed version for your release line: 7.14.4 or 8.6.1.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2024-36414 being exploited?

There is no known exploitation of CVE-2024-36414 in the wild and no public exploit code.

All Salesagility Suitecrm vulnerabilities

Sources

Also known as BIT-suitecrm-2024-36414, GHSA-wg74-772c-8gr7.

Is CVE-2024-36414 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free