CVE-2024-36416 SuiteCRM v4 API Excessive log data DOS

High 8.6 Published Updated

Attackers can cause denial of service in SuiteCRM by exploiting a deprecated v4 API that logs excessive data without rotation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-36416?

CVE-2024-36416 is a high-severity denial of service vulnerability in Salesagility Suitecrm, published on 10 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SuiteCRM is an open-source Customer Relationship Management (CRM) software application. Prior to versions 7.14.4 and 8.6.1, a deprecated v4 API example with no log rotation allows denial of service by logging excessive data. Versions 7.14.4 and 8.6.1 contain a fix for this issue.

Weakness: CWE-779

Which versions are affected by CVE-2024-36416?

1 open source package ship an affected version, including suitecrm. It affects 1 product.

PackageAffectedFixed in
suitecrm BitnamiAll versions7.14.4, 8.6.1

Products include Salesagility Suitecrm.

How do I fix CVE-2024-36416?

Upgrade suitecrm to a fixed version for your release line: 7.14.4 or 8.6.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-36416 being exploited?

There is no known exploitation of CVE-2024-36416 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Salesagility Suitecrm vulnerabilities

Sources

Also known as BIT-suitecrm-2024-36416, GHSA-jrpp-22g3-2j77.

Is CVE-2024-36416 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free