CVE-2024-36418 SuiteCRM authenticated RCE using connectors

High 8.6 Published Updated

Authenticated attackers can execute arbitrary code via SuiteCRM connectors, requiring an upgrade to secure the CRM system.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-36418?

CVE-2024-36418 is a high-severity code injection vulnerability in Salesagility Suitecrm, published on 10 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

SuiteCRM is an open-source Customer Relationship Management (CRM) software application. Prior to versions 7.14.4 and 8.6.1, a vulnerability in connectors allows an authenticated user to perform a remote code execution attack. Versions 7.14.4 and 8.6.1 contain a fix for this issue.

Weakness: CWE-22

Which versions are affected by CVE-2024-36418?

1 open source package ship an affected version, including suitecrm. It affects 1 product.

PackageAffectedFixed in
suitecrm BitnamiAll versions7.14.4, 8.6.1

Products include Salesagility Suitecrm.

How do I fix CVE-2024-36418?

Upgrade suitecrm to a fixed version for your release line: 7.14.4 or 8.6.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-36418 being exploited?

There is no known exploitation of CVE-2024-36418 in the wild and no public exploit code.

All Salesagility Suitecrm vulnerabilities

Sources

Also known as BIT-suitecrm-2024-36418, GHSA-mfj5-37v4-vh5w.

Is CVE-2024-36418 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free