# CVE-2024-36471: Apache Allura: sensitive information exposure via DNS rebinding

> Project administrators can exploit DNS rebinding in the import feature to read data from internal services, exposing sensitive information.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jun 2024
- **Updated:** 13 Sep 2024
- **Also known as:** GHSA-2q7f-pr29-qfh5

## What is CVE-2024-36471?

CVE-2024-36471 is a high-severity server-side request forgery vulnerability in Apache Allura, published on 10 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Import functionality is vulnerable to DNS rebinding attacks between verification and processing of the URL.  Project administrators can run these imports, which could cause Allura to read from internal services and expose them.

This issue affects Apache Allura from 1.0.1 through 1.16.0.

Users are recommended to upgrade to version 1.17.0, which fixes the issue.  If you are unable to upgrade, set "disable_entry_points.allura.importers = forge-tracker, forge-discussion" in your .ini config file.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-36471?

It affects 1 product.


Products: Apache Allura.

## How do I fix CVE-2024-36471?

No fix has been published for CVE-2024-36471 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-36471 being exploited?

There is no known exploitation of CVE-2024-36471 in the wild and no public exploit code.

## Other vulnerabilities in Apache Allura

- [CVE-2026-73240](https://insights.sbomify.com/CVE-2026-73240/): Apache Allura: Git command injection (critical 9.8)
- [CVE-2026-69223](https://insights.sbomify.com/CVE-2026-69223/): Apache Allura: Server-side request forgery (critical 9.1)
- [CVE-2018-1299](https://insights.sbomify.com/CVE-2018-1299/): Path traversal in Apache Allura (high 7.5)
- [CVE-2026-73239](https://insights.sbomify.com/CVE-2026-73239/): Apache Allura: Missing permission checks IDOR (medium 6.5)
- [CVE-2026-73237](https://insights.sbomify.com/CVE-2026-73237/): Apache Allura: XSS in markdown pipeline (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36471 and fix it if it is affected.

What it is: CVE-2024-36471 is a high-severity server-side request forgery vulnerability in Apache Allura, published on 10 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36471 in the wild and no public exploit code.

Affected product: Apache Allura. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36471/ (Markdown: https://insights.sbomify.com/CVE-2024-36471/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36471
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36471
- OSV: https://osv.dev/vulnerability/CVE-2024-36471

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36471/
Summaries are generated and may contain mistakes; the official description above is the record.
