CVE-2024-36492 Existing local user overwritten by malicious remote

High 7.4 Published Updated

A malicious remote user can overwrite existing local users during shared channel synchronization, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-36492?

CVE-2024-36492 is a high-severity missing authorization vulnerability in Mattermost Mattermost, published on 1 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5, 9.8.x <= 9.8.1 fail to disallow the modification of local users when syncing users in shared channels. which allows a malicious remote to overwrite an existing local user.

Weakness: CWE-284

Which versions are affected by CVE-2024-36492?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.7
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.7
github.com/mattermost/mattermost/server/v8 GoFrom 9.7.09.7.6
github.com/mattermost/mattermost/server/v8 GoFrom 9.7.09.7.6
github.com/mattermost/mattermost/server/v8 GoFrom 9.8.09.8.2
6 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 9.8.09.8.2
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.1
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.1
github.com/mattermost/mattermost-server GoFrom 9.5.0+incompatible9.5.7+incompatible, 9.7.6+incompatible, 9.8.2+incompatible, 9.9.1+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost.

How do I fix CVE-2024-36492?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.5.7, 9.7.6, 9.8.2 or 9.9.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-36492 being exploited?

There is no known exploitation of CVE-2024-36492 in the wild and no public exploit code.

All Mattermost Mattermost vulnerabilities

Sources

Also known as GHSA-56mc-f9w7-2wxq, GO-2024-3025.

Is CVE-2024-36492 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free