# CVE-2024-36537: Missing authorization in n/a

> Attackers can access sensitive data and escalate privileges by exploiting insecure permissions to obtain the service account token in cert-manager.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-cert-manager-2024-36537, CLEANSTART-2026-PK76681, GHSA-9cfq-668r-pxhc

## What is CVE-2024-36537?

CVE-2024-36537 is a high-severity missing authorization vulnerability in n/a, published on 24 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Insecure permissions in cert-manager v1.14.4 allows attackers to access sensitive data and escalate privileges by obtaining the service account's token.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-36537?

1 open source package ship an affected version, including cert-manager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cert-manager` | Bitnami | From 1.14.4 | 1.14.5 |

Products: Cert-Manager Cert-Manager.

## How do I fix CVE-2024-36537?

Upgrade cert-manager to 1.14.5 or later.

## Is CVE-2024-36537 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36537 exists.

## Other vulnerabilities in n/a

- [CVE-2026-25518](https://insights.sbomify.com/CVE-2026-25518/): cert-manager-controller DoS via Specially Crafted DNS Response (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36537 and fix it if it is affected.

What it is: CVE-2024-36537 is a high-severity missing authorization vulnerability in n/a, published on 24 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36537 exists.

Affected packages and fixed versions:
- cert-manager (Bitnami): affected from 1.14.4; fixed in 1.14.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36537/ (Markdown: https://insights.sbomify.com/CVE-2024-36537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36537
- OSV: https://osv.dev/vulnerability/CVE-2024-36537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36537/
Summaries are generated and may contain mistakes; the official description above is the record.
