# CVE-2024-36539: Missing authorization in n/a

> Attackers can access sensitive data and escalate privileges by obtaining the service account token due to insecure permissions in Contour.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-contour-2024-36539, GHSA-6xhf-2fjj-wq6j

## What is CVE-2024-36539?

CVE-2024-36539 is a critical missing authorization vulnerability in n/a, published on 24 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Insecure permissions in contour v1.28.3 allows attackers to access sensitive data and escalate privileges by obtaining the service account's token.

Weakness: CWE-277 (Insecure Inherited Permissions)

## Which versions are affected by CVE-2024-36539?

1 open source package ship an affected version, including contour. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contour` | Bitnami | From 1.28.3 | 1.28.4 |

Products: Projectcontour Contour.

## How do I fix CVE-2024-36539?

Upgrade contour to 1.28.4 or later.

## Is CVE-2024-36539 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36539 exists.

Public exploit code:

- https://github.com/Abdurahmon3236/CVE-2024-36539 (github_poc): https://github.com/Abdurahmon3236/CVE-2024-36539

## Other vulnerabilities in n/a

- [CVE-2021-32783](https://insights.sbomify.com/CVE-2021-32783/): Authorization bypass in Contour (high 8.5)
- [CVE-2026-41246](https://insights.sbomify.com/CVE-2026-41246/): Contour: Lua code injection via Cookie Path Rewrite Policy (high 8.1)
- [CVE-2020-15127](https://insights.sbomify.com/CVE-2020-15127/): Denial of service in Contour (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36539 and fix it if it is affected.

What it is: CVE-2024-36539 is a critical missing authorization vulnerability in n/a, published on 24 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36539 exists.

Affected packages and fixed versions:
- contour (Bitnami): affected from 1.28.3; fixed in 1.28.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36539/ (Markdown: https://insights.sbomify.com/CVE-2024-36539/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36539
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36539
- OSV: https://osv.dev/vulnerability/CVE-2024-36539

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36539/
Summaries are generated and may contain mistakes; the official description above is the record.
