# CVE-2024-3656: Keycloak: unguarded admin rest api endpoints allows low privilege users to use administrative functionalities

> Low-privilege users can access administrative endpoints in Keycloak, enabling unauthorized actions and potential data breaches.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2024
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-2cww-fgmg-4jqc

## What is CVE-2024-3656?

CVE-2024-3656 is a high-severity missing authorization vulnerability in Red Hat Build of Keycloak, published on 9 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Keycloak. Certain endpoints in Keycloak's admin REST API allow low-privilege users to access administrative functionalities. This flaw allows users to perform actions reserved for administrators, potentially leading to data breaches or system compromise.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-3656?

2 open source packages ship an affected version, including org.keycloak:keycloak-services.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 24.0.5 |
| `org.keycloak:keycloak-services` | Maven | All versions | 24.0.5 |

## How do I fix CVE-2024-3656?

Upgrade org.keycloak:keycloak-services to 24.0.5 or later.

## Is CVE-2024-3656 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3656 exists.

Public exploit code:

- Keycloak admin API allows low privilege users to use administrative functions (github_poc): https://github.com/h4x0r-dz/CVE-2024-3656
- Keycloak < 24.0.5 - Broken Access Control (nuclei): http/cves/2024/CVE-2024-3656.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3656 and fix it if it is affected.

What it is: CVE-2024-3656 is a high-severity missing authorization vulnerability in Red Hat Build of Keycloak, published on 9 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3656 exists.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 24.0.5
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 24.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3656/ (Markdown: https://insights.sbomify.com/CVE-2024-3656/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3656
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3656
- OSV: https://osv.dev/vulnerability/CVE-2024-3656

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3656/
Summaries are generated and may contain mistakes; the official description above is the record.
