# CVE-2024-36577: Object Resolver Prototype Pollution

> Prototype pollution in js-object-resolver allows attackers to modify object prototypes, potentially leading to code execution or security bypasses.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-qj86-v6m7-4qv2

## What is CVE-2024-36577?

CVE-2024-36577 is a high-severity vulnerability in n/a, published on 17 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

apphp js-object-resolver < 3.1.1 is vulnerable to Prototype Pollution via Module.setNestedProperty.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2024-36577?

2 open source packages ship an affected version, including @apphp/object-resolver.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apphp/object-resolver` | npm | All versions | 3.1.1 |
| `@apphp/object-resolver` | npm | All versions | 3.1.1 |

## How do I fix CVE-2024-36577?

Upgrade @apphp/object-resolver to 3.1.1 or later.

## Is CVE-2024-36577 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36577 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36577 and fix it if it is affected.

What it is: CVE-2024-36577 is a high-severity vulnerability in n/a, published on 17 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36577 exists.

Affected packages and fixed versions:
- @apphp/object-resolver (npm): affected all versions; fixed in 3.1.1
- @apphp/object-resolver (npm): affected all versions; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36577/ (Markdown: https://insights.sbomify.com/CVE-2024-36577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36577
- OSV: https://osv.dev/vulnerability/CVE-2024-36577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36577/
Summaries are generated and may contain mistakes; the official description above is the record.
