# CVE-2024-36578: @akbr/update Prototype Pollution

> Prototype pollution in akbr update allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-mj4p-gmhr-92g3

## What is CVE-2024-36578?

CVE-2024-36578 is a medium-severity vulnerability in n/a, published on 17 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

akbr update 1.0.0 is vulnerable to Prototype Pollution via update/index.js.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2024-36578?

2 open source packages ship an affected version, including @akbr/update.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@akbr/update` | npm | All versions to 1.0.0 | None |
| `@akbr/update` | npm | All versions to 1.0.0 | None |

## How do I fix CVE-2024-36578?

No fix has been published for CVE-2024-36578 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-36578 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36578 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36578 and fix it if it is affected.

What it is: CVE-2024-36578 is a medium-severity vulnerability in n/a, published on 17 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36578 exists.

Affected packages and fixed versions:
- @akbr/update (npm): affected all versions up to 1.0.0; no fix listed
- @akbr/update (npm): affected all versions up to 1.0.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36578/ (Markdown: https://insights.sbomify.com/CVE-2024-36578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36578
- OSV: https://osv.dev/vulnerability/CVE-2024-36578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36578/
Summaries are generated and may contain mistakes; the official description above is the record.
