CVE-2024-36623 Moby Race Condition vulnerability
Attackers can trigger concurrent writes in Moby streamformatter causing data corruption or crashes, impacting Docker Engine users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-36623?
CVE-2024-36623 is a high-severity vulnerability in n/a, published on 29 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
moby through v25.0.3 has a Race Condition vulnerability in the streamformatter package which can be used to trigger multiple concurrent write operations resulting in data corruption or application crashes.
Weakness: CWE-362
Which versions are affected by CVE-2024-36623?
3 open source packages ship an affected version, including github.com/moby/moby. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/moby/moby Go | All versions | 25.0.4 |
github.com/moby/moby Go | All versions | 25.0.4 |
github.com/moby/moby Go | All versions | 26.0.0+incompatible |
Products include Mobyproject Moby.
How do I fix CVE-2024-36623?
Upgrade github.com/moby/moby to a fixed version for your release line: 25.0.4 or 26.0.0+incompatible.
Is CVE-2024-36623 being exploited?
There is no known exploitation of CVE-2024-36623 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2023-28840 moby/moby's dockerd daemon encrypted overlay network may be unauthenticated
- CVE-2018-12608 Docker Authentication Bypass
- CVE-2024-24557 Moby classic builder cache poisoning
- CVE-2023-28841 moby/moby's dockerd daemon encrypted overlay network traffic may be unencrypted
- CVE-2023-28842 moby/moby's dockerd daemon encrypted overlay network with a single endpoint is unauthenticated
Sources
Also known as AZL-53801, AZL-53804, AZL-53819, AZL-53824, AZL-53827, DEBIAN-CVE-2024-36623 and 9 more.