# CVE-2024-36623: Moby Race Condition vulnerability

> Attackers can trigger concurrent writes in Moby streamformatter causing data corruption or crashes, impacting Docker Engine users.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2024
- **Updated:** 1 May 2025
- **Also known as:** AZL-53801, AZL-53804, AZL-53819, AZL-53824, AZL-53827, DEBIAN-CVE-2024-36623, GHSA-gh5c-3h97-2f3q, GO-2024-3305, MINI-p9vg-rx33-3887, MINI-xqj9-mr24-j37v, OESA-2024-2555, OESA-2024-2556, OESA-2024-2557, ROOT-OS-DEBIAN-12-CVE-2024-36623, UBUNTU-CVE-2024-36623

## What is CVE-2024-36623?

CVE-2024-36623 is a high-severity vulnerability in n/a, published on 29 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

moby through v25.0.3 has a Race Condition vulnerability in the streamformatter package which can be used to trigger multiple concurrent write operations resulting in data corruption or application crashes.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2024-36623?

3 open source packages ship an affected version, including github.com/moby/moby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/moby/moby` | Go | All versions | 25.0.4 |
| `github.com/moby/moby` | Go | All versions | 25.0.4 |
| `github.com/moby/moby` | Go | All versions | 26.0.0+incompatible |

Products: Mobyproject Moby.

## How do I fix CVE-2024-36623?

Upgrade github.com/moby/moby to a fixed version for your release line: 25.0.4 or 26.0.0+incompatible.

## Is CVE-2024-36623 being exploited?

There is no known exploitation of CVE-2024-36623 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-28840](https://insights.sbomify.com/CVE-2023-28840/): moby/moby's dockerd daemon encrypted overlay network may be unauthenticated (high 7.5)
- [CVE-2018-12608](https://insights.sbomify.com/CVE-2018-12608/): Docker Authentication Bypass (high 7.5)
- [CVE-2024-24557](https://insights.sbomify.com/CVE-2024-24557/): Moby classic builder cache poisoning (medium 6.9)
- [CVE-2023-28841](https://insights.sbomify.com/CVE-2023-28841/): moby/moby's dockerd daemon encrypted overlay network traffic may be unencrypted (medium 6.8)
- [CVE-2023-28842](https://insights.sbomify.com/CVE-2023-28842/): moby/moby's dockerd daemon encrypted overlay network with a single endpoint is unauthenticated (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36623 and fix it if it is affected.

What it is: CVE-2024-36623 is a high-severity vulnerability in n/a, published on 29 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36623 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/moby/moby (Go): affected all versions; fixed in 25.0.4
- github.com/moby/moby (Go): affected all versions; fixed in 25.0.4
- github.com/moby/moby (Go): affected all versions; fixed in 26.0.0+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36623/ (Markdown: https://insights.sbomify.com/CVE-2024-36623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36623
- OSV: https://osv.dev/vulnerability/CVE-2024-36623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36623/
Summaries are generated and may contain mistakes; the official description above is the record.
