# CVE-2024-36676: BookStack Incorrect Access Control vulnerability

> Attackers can confirm existing system users and cause denial of service via targeted notification emails through public forms in BookStack.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-pj36-fcrg-327j

## What is CVE-2024-36676?

CVE-2024-36676 is a high-severity vulnerability in n/a, published on 9 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Incorrect access control in BookStack before v24.05.1 allows attackers to confirm existing system users and perform targeted notification email DoS via public facing forms.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-36676?

2 open source packages ship an affected version, including ssddanbrown/bookstack.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ssddanbrown/bookstack` | Packagist | All versions | 24.05.1 |
| `ssddanbrown/bookstack` | Packagist | All versions | 24.05.1 |

## How do I fix CVE-2024-36676?

Upgrade ssddanbrown/bookstack to 24.05.1 or later.

## Is CVE-2024-36676 being exploited?

There is no known exploitation of CVE-2024-36676 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36676 and fix it if it is affected.

What it is: CVE-2024-36676 is a high-severity vulnerability in n/a, published on 9 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36676 in the wild and no public exploit code.

Affected packages and fixed versions:
- ssddanbrown/bookstack (Packagist): affected all versions; fixed in 24.05.1
- ssddanbrown/bookstack (Packagist): affected all versions; fixed in 24.05.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36676/ (Markdown: https://insights.sbomify.com/CVE-2024-36676/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36676
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36676
- OSV: https://osv.dev/vulnerability/CVE-2024-36676

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36676/
Summaries are generated and may contain mistakes; the official description above is the record.
