{"answers":{"affected":"3 open source packages ship an affected version, including opencart/opencart and opencart. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36694 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2024-36694 is a high-severity code injection vulnerability in n/a, published on 18 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-36694 and fix it if it is affected.\n\nWhat it is: CVE-2024-36694 is a high-severity code injection vulnerability in n/a, published on 18 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36694 exists.\n\nAffected packages and fixed versions:\n- opencart/opencart (Packagist): affected all versions up to 4.0.2.3; no fix listed\n- opencart/opencart (Packagist): affected all versions up to 4.0.2.3; no fix listed\n- opencart (Bitnami): affected all versions; fixed in 4.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-36694/ (Markdown: https://insights.sbomify.com/CVE-2024-36694/index.md)","id":"CVE-2024-36694","markdown":"https://insights.sbomify.com/CVE-2024-36694/index.md","name":"CVE-2024-36694","record":{"aliases":["BIT-opencart-2024-36694","CVE-2024-40420","GHSA-xrh7-2gfq-4rcq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCart e-commerce","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary code via Server-Side Template Injection in the OpenCart Theme Editor, compromising the web application.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opencart","vendor":"opencart"}],"cvss":{"score":7.2,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"openCart Server-Side Template Injection (SSTI) vulnerability","id":"CVE-2024-36694","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":5,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-36697"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"opencart","purl":"pkg:bitnami/opencart","source":"BIT-opencart-2024-36694"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["4.0.2.3"],"package":"opencart/opencart","purl":null,"source":"GHSA-xrh7-2gfq-4rcq"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["4.0.2.3"],"package":"opencart/opencart","purl":"pkg:composer/opencart/opencart","source":"GHSA-xrh7-2gfq-4rcq"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2024-36691"},"products":["n/a"],"published":"2024-12-18","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2023-40834","kev_date_added":null,"published":"2023-09-12"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2014-3990","kev_date_added":null,"published":"2018-03-20"},{"cvss_score":8.8,"headline":"OpenCart Core 4.0.2.3 SQL Injection via search Parameter","id":"CVE-2024-58341","kev_date_added":null,"published":"2026-03-25"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2023-47444","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.8,"headline":"OpenCart Cross-Site Request Forgery (CSRF)","id":"CVE-2018-13067","kev_date_added":null,"published":"2018-07-02"},{"cvss_score":8.1,"headline":"Path Traversal in OpenCart versions 4.0.0.0 to 4.0.2.2","id":"CVE-2023-2315","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":8,"headline":"OpenCart Path Traversal","id":"CVE-2018-11494","kev_date_added":null,"published":"2018-05-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-23","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via Server-Side Template Injection in the OpenCart Theme Editor, compromising the web application.","url":"https://insights.sbomify.com/CVE-2024-36694/"}