# CVE-2024-36694: openCart Server-Side Template Injection (SSTI) vulnerability

> Attackers can execute arbitrary code via Server-Side Template Injection in the OpenCart Theme Editor, compromising the web application.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Dec 2024
- **Updated:** 23 Jan 2025
- **Also known as:** BIT-opencart-2024-36694, CVE-2024-40420, GHSA-xrh7-2gfq-4rcq

## What is CVE-2024-36694?

CVE-2024-36694 is a high-severity code injection vulnerability in n/a, published on 18 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-36694?

3 open source packages ship an affected version, including opencart/opencart and opencart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencart/opencart` | Packagist | All versions to 4.0.2.3 | None |
| `opencart/opencart` | Packagist | All versions to 4.0.2.3 | None |
| `opencart` | Bitnami | All versions | 4.1.0 |

Products: Opencart Opencart.

## How do I fix CVE-2024-36694?

Upgrade to a fixed version.

## Is CVE-2024-36694 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36694 exists.

## Other vulnerabilities in n/a

- [CVE-2023-40834](https://insights.sbomify.com/CVE-2023-40834/): Auth bypass in n/a (critical 9.8)
- [CVE-2014-3990](https://insights.sbomify.com/CVE-2014-3990/): Deserialization in n/a (critical 9.8)
- [CVE-2024-58341](https://insights.sbomify.com/CVE-2024-58341/): OpenCart Core 4.0.2.3 SQL Injection via search Parameter (high 8.8)
- [CVE-2023-47444](https://insights.sbomify.com/CVE-2023-47444/): Code injection in n/a (high 8.8)
- [CVE-2018-13067](https://insights.sbomify.com/CVE-2018-13067/): OpenCart Cross-Site Request Forgery (CSRF) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36694 and fix it if it is affected.

What it is: CVE-2024-36694 is a high-severity code injection vulnerability in n/a, published on 18 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36694 exists.

Affected packages and fixed versions:
- opencart/opencart (Packagist): affected all versions up to 4.0.2.3; no fix listed
- opencart/opencart (Packagist): affected all versions up to 4.0.2.3; no fix listed
- opencart (Bitnami): affected all versions; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36694/ (Markdown: https://insights.sbomify.com/CVE-2024-36694/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36694
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36694
- OSV: https://osv.dev/vulnerability/CVE-2024-36694

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36694/
Summaries are generated and may contain mistakes; the official description above is the record.
