# CVE-2024-36827: ebookmeta XML External Entity vulnerability

> Attackers can exploit an XML External Entity vulnerability in the ebookmeta library to access sensitive information or cause a Denial of Service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2024
- **Updated:** 28 Mar 2025
- **Also known as:** GHSA-whf4-fpj8-pgg8, PYSEC-2024-76

## What is CVE-2024-36827?

CVE-2024-36827 is a high-severity vulnerability in n/a, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An XML External Entity (XXE) vulnerability in the ebookmeta.get_metadata function of ebookmeta before v1.2.8 allows attackers to access sensitive information or cause a Denial of Service (DoS) via crafted XML input.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-36827?

3 open source packages ship an affected version, including ebookmeta. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ebookmeta` | PyPI | All versions | 1.2.8 |
| `ebookmeta` | PyPI | All versions | 1.2.8 |
| `ebookmeta` | PyPI | All versions | 1.2.8 |

Products: Dnkorpushov Ebookmeta.

## How do I fix CVE-2024-36827?

Upgrade ebookmeta to 1.2.8 or later.

## Is CVE-2024-36827 being exploited?

There is no known exploitation of CVE-2024-36827 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-37388](https://insights.sbomify.com/CVE-2024-37388/): ebookmeta XML External Entity vulnerability (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36827 and fix it if it is affected.

What it is: CVE-2024-36827 is a high-severity vulnerability in n/a, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36827 in the wild and no public exploit code.

Affected packages and fixed versions:
- ebookmeta (PyPI): affected all versions; fixed in 1.2.8
- ebookmeta (PyPI): affected all versions; fixed in 1.2.8
- ebookmeta (PyPI): affected all versions; fixed in 1.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36827/ (Markdown: https://insights.sbomify.com/CVE-2024-36827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36827
- OSV: https://osv.dev/vulnerability/CVE-2024-36827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36827/
Summaries are generated and may contain mistakes; the official description above is the record.
