CVE-2024-37014 Langflow remote code execution vulnerability
Remote attackers can execute arbitrary Python code by sending malicious scripts to the custom component API endpoint in Langflow.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-37014?
CVE-2024-37014 is a high-severity code injection vulnerability in Langflow Langflow, published on 10 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Langflow through 0.6.19 allows remote code execution if untrusted users are able to reach the "POST /api/v1/custom_component" endpoint and provide a Python script.
Weakness: CWE-94
Which versions are affected by CVE-2024-37014?
3 open source packages ship an affected version, including langflow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
langflow PyPI | All versions | 1.0.0a3 |
langflow PyPI | All versions | 1.0.15 |
langflow PyPI | All versions | 1.0.15 |
Products include Langflow Langflow.
How do I fix CVE-2024-37014?
Upgrade langflow to a fixed version for your release line: 1.0.0a3 or 1.0.15.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-37014 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37014 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Langflow Langflow
Sources
Also known as GHSA-qg33-x2c5-6p44, PYSEC-2024-177.