# CVE-2024-37031: activeadmin vulnerable to stored persistent cross-site scripting (XSS) in dynamic form legends

> Stored XSS in Active Admin allows attackers to execute arbitrary scripts via entity names, impacting Ruby on Rails applications using this admin framework.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jun 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-9mg6-x45v-hcfm

## What is CVE-2024-37031?

CVE-2024-37031 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Active Admin (aka activeadmin) framework before 3.2.2 for Ruby on Rails allows stored XSS in certain situations where users can create entities (to be later edited in forms) with arbitrary names, aka a "dynamic form legends" issue. 4.0.0.beta7 is also a fixed version.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-37031?

4 open source packages ship an affected version, including activeadmin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activeadmin` | RubyGems | All versions | 3.2.2 |
| `activeadmin` | RubyGems | All versions | 3.2.2 |
| `activeadmin` | RubyGems | From 4.0.0.beta1 | 4.0.0.beta7 |
| `activeadmin` | RubyGems | From 4.0.0.beta1 | 4.0.0.beta7 |

## How do I fix CVE-2024-37031?

Upgrade activeadmin to a fixed version for your release line: 3.2.2 or 4.0.0.beta7.

## Is CVE-2024-37031 being exploited?

There is no known exploitation of CVE-2024-37031 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37031 and fix it if it is affected.

What it is: CVE-2024-37031 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-37031 in the wild and no public exploit code.

Affected packages and fixed versions:
- activeadmin (RubyGems): affected all versions; fixed in 3.2.2
- activeadmin (RubyGems): affected all versions; fixed in 3.2.2
- activeadmin (RubyGems): affected from 4.0.0.beta1; fixed in 4.0.0.beta7
- activeadmin (RubyGems): affected from 4.0.0.beta1; fixed in 4.0.0.beta7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37031/ (Markdown: https://insights.sbomify.com/CVE-2024-37031/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37031
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37031
- OSV: https://osv.dev/vulnerability/CVE-2024-37031

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37031/
Summaries are generated and may contain mistakes; the official description above is the record.
