# CVE-2024-37032: Ollama does not validate the format of the digest (sha256 with 64 hex digits)

> Attackers can bypass digest validation to access or modify arbitrary files via path traversal in Ollama model handling.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2024
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-8hqg-whrw-pv92, GO-2024-2901

## What is CVE-2024-37032?

CVE-2024-37032 is a high-severity path traversal vulnerability in n/a, published on 31 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Ollama before 0.1.34 does not validate the format of the digest (sha256 with 64 hex digits) when getting the model path, and thus mishandles the TestGetBlobsPath test cases such as fewer than 64 hex digits, more than 64 hex digits, or an initial ../ substring.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-37032?

3 open source packages ship an affected version, including github.com/ollama/ollama. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ollama/ollama` | Go | All versions | 0.1.34 |
| `github.com/ollama/ollama` | Go | All versions | 0.1.34 |
| `github.com/ollama/ollama` | Go | All versions | 0.1.34 |

Products: Ollama Ollama.

## How do I fix CVE-2024-37032?

Upgrade github.com/ollama/ollama to 0.1.34 or later.

## Is CVE-2024-37032 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37032 exists.

Public exploit code:

- Path traversal in Ollama with rogue registry server (github_poc): https://github.com/Bi0x/CVE-2024-37032
- CVE-2024-45436 (github_poc): https://github.com/pankass/CVE-2024-37032_CVE-2024-45436
- CVE-2024-37032 (Probllama) PoC for Ollama ≤0.1.33: path traversal and arbitrary file write via model digest handling, leading to automated privilege escalation. (github_poc): https://github.com/itzSh4dowxZ/CVE-2024-37032-PoC
- CVE-2024-37032 scanner (github_poc): https://github.com/ahboon/CVE-2024-37032-scanner
- Ollama Model Registry Path Traversal RCE (metasploit)
- Ollama - Remote Code Execution (nuclei): http/cves/2024/CVE-2024-37032.yaml

## Other vulnerabilities in n/a

- [CVE-2025-63389](https://insights.sbomify.com/CVE-2025-63389/): Ollama Platform has missing authentication enabling attackers to perform model management operations (critical 9.8)
- [CVE-2024-45436](https://insights.sbomify.com/CVE-2024-45436/): Ollama can extract members of a ZIP archive outside of the parent directory (critical 9.1)
- [CVE-2026-7482](https://insights.sbomify.com/CVE-2026-7482/): Ollama heap out-of-bounds read in GGUF tensor parsing leaks server process memory to unauthenticated remote attackers (high 8.8)
- [CVE-2025-15514](https://insights.sbomify.com/CVE-2025-15514/): Ollama Multi-Modal Model Image Processing NULL Pointer Dereference (high 8.7)
- [CVE-2024-39720](https://insights.sbomify.com/CVE-2024-39720/): Ollama Out-of-bounds Read (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37032 and fix it if it is affected.

What it is: CVE-2024-37032 is a high-severity path traversal vulnerability in n/a, published on 31 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37032 exists.

Affected packages and fixed versions:
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.1.34
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.1.34
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.1.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37032/ (Markdown: https://insights.sbomify.com/CVE-2024-37032/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37032
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37032
- OSV: https://osv.dev/vulnerability/CVE-2024-37032

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37032/
Summaries are generated and may contain mistakes; the official description above is the record.
