CVE-2024-37058 MLFlow unsafe deserialization

High 8.8 Published Updated

Attackers can execute arbitrary code on user systems by uploading malicious Langchain AgentExecutor models to MLflow.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-37058?

CVE-2024-37058 is a high-severity unsafe deserialization vulnerability in Lfprojects Mlflow, published on 4 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Deserialization of untrusted data can occur in versions of the MLflow platform running version 2.5.0 or newer, enabling a maliciously uploaded Langchain AgentExecutor model to run arbitrary code on an end user’s system when interacted with.

Weakness: CWE-502

Which versions are affected by CVE-2024-37058?

4 open source packages ship an affected version, including mlflow. It affects 1 product.

PackageAffectedFixed in
mlflow BitnamiFrom 2.5.02.14.2
mlflow PyPIFrom 2.5.0 to 2.14.1None
mlflow PyPIFrom 2.5.0 to 2.14.1None
mlflow PyPIFrom 2.5.0 to 2.14.1None

Products include Lfprojects Mlflow.

How do I fix CVE-2024-37058?

Upgrade mlflow to 2.14.2 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2024-37058 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37058 exists.

All Lfprojects Mlflow vulnerabilities

Sources

Also known as BIT-mlflow-2024-37058, GHSA-cwgg-w6mp-w9hg, PYSEC-2026-1648.

Is CVE-2024-37058 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free