CVE-2024-37061 MLFlow improper input validation

High 8.8 Published Updated

Attackers can execute arbitrary code on user systems by providing a maliciously crafted MLproject file to the MLflow platform.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-37061?

CVE-2024-37061 is a high-severity code injection vulnerability in Lfprojects Mlflow, published on 4 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Remote Code Execution can occur in versions of the MLflow platform running version 1.11.0 or newer, enabling a maliciously crafted MLproject to execute arbitrary code on an end user’s system when run.

Weakness: CWE-94

Which versions are affected by CVE-2024-37061?

4 open source packages ship an affected version, including mlflow. It affects 1 product.

PackageAffectedFixed in
mlflow BitnamiFrom 1.11.02.13.2
mlflow PyPIFrom 1.11.0 to 2.13.1None
mlflow PyPIFrom 1.11.0 to 2.13.1None
mlflow PyPIFrom 1.11.0 to 2.13.1None

Products include Lfprojects Mlflow.

How do I fix CVE-2024-37061?

Upgrade mlflow to 2.13.2 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-37061 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37061 exists.

All Lfprojects Mlflow vulnerabilities

Sources

Also known as BIT-mlflow-2024-37061, GHSA-pqcv-qw2r-r859, PYSEC-2026-1657.

Is CVE-2024-37061 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free