# CVE-2024-37061: MLFlow improper input validation

> Attackers can execute arbitrary code on user systems by providing a maliciously crafted MLproject file to the MLflow platform.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-mlflow-2024-37061, GHSA-pqcv-qw2r-r859, PYSEC-2026-1657

## What is CVE-2024-37061?

CVE-2024-37061 is a high-severity code injection vulnerability in Lfprojects Mlflow, published on 4 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Remote Code Execution can occur in versions of the MLflow platform running version 1.11.0 or newer, enabling a maliciously crafted MLproject to execute arbitrary code on an end user’s system when run.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-37061?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | From 1.11.0 | 2.13.2 |
| `mlflow` | PyPI | From 1.11.0 to 2.13.1 | None |
| `mlflow` | PyPI | From 1.11.0 to 2.13.1 | None |
| `mlflow` | PyPI | From 1.11.0 to 2.13.1 | None |

Products: Lfprojects Mlflow.

## How do I fix CVE-2024-37061?

Upgrade mlflow to 2.13.2 or later.

## Is CVE-2024-37061 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37061 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37061 and fix it if it is affected.

What it is: CVE-2024-37061 is a high-severity code injection vulnerability in Lfprojects Mlflow, published on 4 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37061 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected from 1.11.0; fixed in 2.13.2
- mlflow (PyPI): affected from 1.11.0 up to 2.13.1; no fix listed
- mlflow (PyPI): affected from 1.11.0 up to 2.13.1; no fix listed
- mlflow (PyPI): affected from 1.11.0 up to 2.13.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37061/ (Markdown: https://insights.sbomify.com/CVE-2024-37061/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37061
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37061
- OSV: https://osv.dev/vulnerability/CVE-2024-37061

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37061/
Summaries are generated and may contain mistakes; the official description above is the record.
