{"answers":{"affected":"3 open source packages ship an affected version, including ydata-profiling.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37062 exists.","fix":"No fix has been published for CVE-2024-37062 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-37062 is a high-severity unsafe deserialization vulnerability in YdataAI ydata-profiling, published on 4 Jun 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-37062 and fix it if it is affected.\n\nWhat it is: CVE-2024-37062 is a high-severity unsafe deserialization vulnerability in YdataAI ydata-profiling, published on 4 Jun 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37062 exists.\n\nAffected packages and fixed versions:\n- ydata-profiling (PyPI): affected from 3.7.0 up to 4.8.3; no fix listed\n- ydata-profiling (PyPI): affected from 3.7.0 up to 4.8.3; no fix listed\n- ydata-profiling (PyPI): affected from 3.7.0 up to 4.8.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-37062/ (Markdown: https://insights.sbomify.com/CVE-2024-37062/index.md)","id":"CVE-2024-37062","markdown":"https://insights.sbomify.com/CVE-2024-37062/index.md","name":"CVE-2024-37062","record":{"aliases":["GHSA-fpvj-m2h6-6wc5","PYSEC-2026-2062"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python profiling library","requires_auth":"none","summary":"Attackers can execute arbitrary code on user systems by tricking them into loading a maliciously crafted report generated by the ydata-profiling library.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"HiddenLayer","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of untrusted data can occur in versions 3.7.0 or newer of Ydata's ydata-profiling open-source library, enabling a malicously crafted report to run arbitrary code on an end user's system when loaded.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"ydata unsafe deserialization","id":"CVE-2024-37062","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"ydata cross-site scripting","id":"CVE-2024-37063"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["3.7.0"],"last_affected":["4.8.3"],"package":"ydata-profiling","purl":null,"source":"GHSA-fpvj-m2h6-6wc5"},{"ecosystem":"PyPI","fixed":[],"introduced":["3.7.0"],"last_affected":["4.8.3"],"package":"ydata-profiling","purl":"pkg:pypi/ydata-profiling","source":"GHSA-fpvj-m2h6-6wc5"},{"ecosystem":"PyPI","fixed":[],"introduced":["3.7.0"],"last_affected":["4.8.3"],"package":"ydata-profiling","purl":"pkg:pypi/ydata-profiling","source":"PYSEC-2026-2062"}],"prev":{"headline":"MLFlow improper input validation","id":"CVE-2024-37061"},"products":["ydata-profiling"],"published":"2024-06-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["YdataAI"]},"summary":"Attackers can execute arbitrary code on user systems by tricking them into loading a maliciously crafted report generated by the ydata-profiling library.","url":"https://insights.sbomify.com/CVE-2024-37062/"}