{"answers":{"affected":"3 open source packages ship an affected version, including skops.","exploited":"There is no known exploitation of CVE-2024-37065 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-37065 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-37065 is a high-severity unsafe deserialization vulnerability in Skops-dev Skops, published on 4 Jun 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-37065 and fix it if it is affected.\n\nWhat it is: CVE-2024-37065 is a high-severity unsafe deserialization vulnerability in Skops-dev Skops, published on 4 Jun 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-37065 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- skops (PyPI): affected from 0.6 up to 0.9; no fix listed\n- skops (PyPI): affected from 0.6 up to 0.9; no fix listed\n- skops (PyPI): affected from 0.6 up to 0.9; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-37065/ (Markdown: https://insights.sbomify.com/CVE-2024-37065/index.md)","id":"CVE-2024-37065","markdown":"https://insights.sbomify.com/CVE-2024-37065/index.md","name":"CVE-2024-37065","record":{"aliases":["GHSA-q49c-6v6g-wgq3","PYSEC-2026-1928"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python machine learning library","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking users into loading maliciously crafted models in the skops Python library.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"HiddenLayer","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of untrusted data can occur in versions 0.6 or newer of the skops python library, enabling a maliciously crafted model to run arbitrary code on an end user's system when loaded.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Skops unsafe deserialization","id":"CVE-2024-37065","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Command injection in Wyze Cam V4 Pro","id":"CVE-2024-37066"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0.6"],"last_affected":["0.9"],"package":"skops","purl":null,"source":"GHSA-q49c-6v6g-wgq3"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.6"],"last_affected":["0.9"],"package":"skops","purl":"pkg:pypi/skops","source":"GHSA-q49c-6v6g-wgq3"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.6"],"last_affected":["0.9"],"package":"skops","purl":"pkg:pypi/skops","source":"PYSEC-2026-1928"}],"prev":{"headline":"ydata unsafe deserialization","id":"CVE-2024-37064"},"products":["Skops"],"published":"2024-06-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["Skops-dev"]},"summary":"Attackers can execute arbitrary code by tricking users into loading maliciously crafted models in the skops Python library.","url":"https://insights.sbomify.com/CVE-2024-37065/"}