CVE-2024-37157 Discourse vulnerable to Server-Side Request Forgery via FastImage

Medium 6.4 Published Updated

Attackers can exploit FastImage to redirect requests to internal IPs, potentially accessing internal resources or bypassing security controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-37157?

CVE-2024-37157 is a medium-severity server-side request forgery vulnerability in Discourse Discourse, published on 3 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch and version 3.3.0.beta4 on the `beta` and `tests-passed` branches, a malicious actor could get the FastImage library to redirect requests to an internal Discourse IP. This issue is patched in version 3.2.3 on the `stable` branch and version 3.3.0.beta4 on the `beta` and `tests-passed` branches. No known workarounds are available.

Weakness: CWE-918

Which versions are affected by CVE-2024-37157?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.2.3

Products include Discourse Discourse.

How do I fix CVE-2024-37157?

Upgrade discourse to 3.2.3 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2024-37157 being exploited?

There is no known exploitation of CVE-2024-37157 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2024-37157, GHSA-46pq-7958-fc68.

Is CVE-2024-37157 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free