{"answers":{"affected":"2 open source packages ship an affected version, including zsa. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-37162 in the wild and no public exploit code.","fix":"Upgrade zsa to 0.3.3 or later.","what":"CVE-2024-37162 is a medium-severity vulnerability in IdoPesok zsa, published on 7 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-37162 and fix it if it is affected.\n\nWhat it is: CVE-2024-37162 is a medium-severity vulnerability in IdoPesok zsa, published on 7 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-37162 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zsa (npm): affected all versions; fixed in 0.3.3\n- zsa (npm): affected all versions; fixed in 0.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-37162/ (Markdown: https://insights.sbomify.com/CVE-2024-37162/index.md)","id":"CVE-2024-37162","markdown":"https://insights.sbomify.com/CVE-2024-37162/index.md","name":"CVE-2024-37162","record":{"aliases":["GHSA-wjmj-h3xc-hxp8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Next.js server actions library","requires_auth":"none","summary":"Attackers can obtain sensitive server environment details like usernames and paths via error messages in production builds of the zsa library.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"zsa","vendor":"idopesok"}],"cvss":{"score":4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"zsa is a library for building typesafe server actions in Next.js. All users are impacted. The zsa application transfers the parse error stack from the server to the client in production build mode. This can potentially reveal sensitive information about the server environment, such as the machine username and directory paths. An attacker could exploit this vulnerability to gain unauthorized access to sensitive server information. This information could be used to plan further attacks or gain a deeper understanding of the server infrastructure. This has been patched on `0.3.3`.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"zsa Generates Error Messages Containing Sensitive Information","id":"CVE-2024-37162","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"SkyScrape Secure API Requests","id":"CVE-2024-37163"},"packages":[{"ecosystem":"npm","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"zsa","purl":null,"source":"GHSA-wjmj-h3xc-hxp8"},{"ecosystem":"npm","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"zsa","purl":"pkg:npm/zsa","source":"GHSA-wjmj-h3xc-hxp8"}],"prev":{"headline":"MeterSphere front-end editor stores XSS vulnerability","id":"CVE-2024-37161"},"products":["zsa"],"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["IdoPesok"]},"summary":"Attackers can obtain sensitive server environment details like usernames and paths via error messages in production builds of the zsa library.","url":"https://insights.sbomify.com/CVE-2024-37162/"}