# CVE-2024-37162: zsa Generates Error Messages Containing Sensitive Information

> Attackers can obtain sensitive server environment details like usernames and paths via error messages in production builds of the zsa library.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-wjmj-h3xc-hxp8

## What is CVE-2024-37162?

CVE-2024-37162 is a medium-severity vulnerability in IdoPesok zsa, published on 7 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

zsa is a library for building typesafe server actions in Next.js. All users are impacted. The zsa application transfers the parse error stack from the server to the client in production build mode. This can potentially reveal sensitive information about the server environment, such as the machine username and directory paths. An attacker could exploit this vulnerability to gain unauthorized access to sensitive server information. This information could be used to plan further attacks or gain a deeper understanding of the server infrastructure. This has been patched on `0.3.3`.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2024-37162?

2 open source packages ship an affected version, including zsa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zsa` | npm | All versions | 0.3.3 |
| `zsa` | npm | All versions | 0.3.3 |

Products: Idopesok Zsa.

## How do I fix CVE-2024-37162?

Upgrade zsa to 0.3.3 or later.

## Is CVE-2024-37162 being exploited?

There is no known exploitation of CVE-2024-37162 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37162 and fix it if it is affected.

What it is: CVE-2024-37162 is a medium-severity vulnerability in IdoPesok zsa, published on 7 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-37162 in the wild and no public exploit code.

Affected packages and fixed versions:
- zsa (npm): affected all versions; fixed in 0.3.3
- zsa (npm): affected all versions; fixed in 0.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37162/ (Markdown: https://insights.sbomify.com/CVE-2024-37162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37162
- OSV: https://osv.dev/vulnerability/CVE-2024-37162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37162/
Summaries are generated and may contain mistakes; the official description above is the record.
