# CVE-2024-37166: ghtml Cross-Site Scripting (XSS) vulnerability


- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-vvhj-v88f-5gxr

## What is CVE-2024-37166?

CVE-2024-37166 is a high-severity vulnerability in gurgunday ghtml, published on 10 Jun 2024. 

### Official description

ghtml is software that uses tagged templates for template engine functionality. It is possible to introduce user-controlled JavaScript code and trigger a Cross-Site Scripting (XSS) vulnerability in some cases. Version 2.0.0 introduces changes to mitigate this issue. Version 2.0.0 contains updated documentation to clarify that while ghtml escapes characters with special meaning in HTML, it does not provide comprehensive protection against all types of XSS attacks in every scenario. This aligns with the approach taken by other template engines. Developers should be cautious and take additional measures to sanitize user input and prevent potential vulnerabilities. Additionally, the backtick character (`) is now also escaped to prevent the creation of strings in most cases where a malicious actor somehow gains the ability to write JavaScript. This does not provide comprehensive protection either.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-37166?

2 open source packages ship an affected version, including ghtml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghtml` | npm | All versions | 2.0.0 |
| `ghtml` | npm | All versions | 2.0.0 |

## How do I fix CVE-2024-37166?

Upgrade ghtml to 2.0.0 or later.

## Is CVE-2024-37166 being exploited?

There is no known exploitation of CVE-2024-37166 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37166 and fix it if it is affected.

What it is: CVE-2024-37166 is a high-severity vulnerability in gurgunday ghtml, published on 10 Jun 2024. 
Exploitation: There is no known exploitation of CVE-2024-37166 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghtml (npm): affected all versions; fixed in 2.0.0
- ghtml (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37166/ (Markdown: https://insights.sbomify.com/CVE-2024-37166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37166
- OSV: https://osv.dev/vulnerability/CVE-2024-37166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37166/
Summaries are generated and may contain mistakes; the official description above is the record.
